Opened 12 years ago

Closed 12 years ago

#3061 closed defect (fixed)

drop down menu should not be associated with the default combo button

Reported by: Becky Gibson Owned by: davidb
Priority: high Milestone: 0.9beta
Component: Accessibility Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Becky Gibson)

setting focus to the default portion (NOT the arrow) of a combo button and pressing the down arrow opens up the associated menu - it should not. The default action part of the button should act like a regular push button (activated via space and enter). Only the arrow portion of the combobutton should cause the menu to be activated.

Currently pressing space on the arrow part of the button does NOT open the menu and it should.

Attachments (6)

3061and3062.diff (1.8 KB) - added by davidb 12 years ago.
patch to go in (tested on FF, IE, WK)
3061-after-regression.diff (4.5 KB) - added by davidb 12 years ago.
proposed fix.
3061-after-regression.3.diff (4.6 KB) - added by davidb 12 years ago.
proposed fix (minor changes to comments)
3061-after-regression.4.diff (4.4 KB) - added by davidb 12 years ago.
added local workaround for 3281
3061-after-regression-after-bills-related-checkin.diff (3.0 KB) - added by davidb 12 years ago.
updated fix to recent trunk changes.
3061-works-around-3281-plus-ie-fixes.diff (4.7 KB) - added by davidb 12 years ago.
fix. tested with mouse and keyboard on FF2 and IE7

Download all attachments as: .zip

Change History (15)

comment:1 Changed 12 years ago by Becky Gibson

Description: modified (diff)

comment:2 Changed 12 years ago by davidb

Status: newassigned

Changed 12 years ago by davidb

Attachment: 3061and3062.diff added

patch to go in (tested on FF, IE, WK)

comment:3 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [8779]) Fix keyboard handling for Combobutton. Fixes #3061 and #3062. Proxy checkin for David Bolter (CLA on file).

comment:4 Changed 12 years ago by Becky Gibson

Resolution: fixed
Status: closedreopened

This also may be a regression due to the change to using a table to create the combo button. The drop down is being displayed when press space or enter on default portion of the button - it should only be dropping down with focus on the arrow portion.

comment:5 Changed 12 years ago by davidb

This is a partial regression, preparing patch.

comment:6 Changed 12 years ago by davidb

Status: reopenednew

comment:7 Changed 12 years ago by davidb

Status: newassigned

Changed 12 years ago by davidb

Attachment: 3061-after-regression.diff added

proposed fix.

Changed 12 years ago by davidb

proposed fix (minor changes to comments)

Changed 12 years ago by davidb

added local workaround for 3281

comment:8 Changed 12 years ago by bill

I haven't tested this but looks fine to me; I assume Becky is going to check it in.

Changed 12 years ago by davidb

updated fix to recent trunk changes.

Changed 12 years ago by davidb

fix. tested with mouse and keyboard on FF2 and IE7

comment:9 Changed 12 years ago by Becky Gibson

Resolution: fixed
Status: assignedclosed

(In [8948]) commit for davidb fixes #3061 added click and key handlers for combobutton; workaround for 3281 event issues in drop down button

Note: See TracTickets for help on using tickets.