Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#3049 closed defect (fixed)

bidi patches for dijit

Reported by: Adam Peller Owned by: Adam Peller
Priority: high Milestone: 0.9
Component: Dijit Version: 0.9
Keywords: bidi Cc:
Blocked By: Blocking:

Description


Attachments (7)

bidi-dijit-r8633.patch (233.2 KB) - added by Adam Peller 12 years ago.
from Justin Yin (IBM) and the IBM GCoC lab (CCLA)
dijit-bidi-fix1-themes-9751.zip (1.6 KB) - added by Adam Peller 12 years ago.
rtl variations on images from Justin Yin (IBM)
dijit-bidi-fix2-button-9802.2.patch (3.3 KB) - added by Adam Peller 12 years ago.
BiDi? patches from Justin for Button
dijit-bidi-fix2-button-9802.patch (2.9 KB) - added by Adam Peller 12 years ago.
BiDi?? patches from Justin for Button
dijit-bidi-fix2-theme-9802.patch (1.4 KB) - added by Adam Peller 12 years ago.
style BiDi? patches from Justin for Button, Tooltip
dijit-bidi-fix2-tooltip-9802.patch (1.7 KB) - added by Adam Peller 12 years ago.
BiDi?? patches from Justin for Tooltip
dijit-bidi-fix-isRtl-12900.patch (3.8 KB) - added by Adam Peller 12 years ago.
update from Evan Huang (IBM)

Download all attachments as: .zip

Change History (30)

Changed 12 years ago by Adam Peller

Attachment: bidi-dijit-r8633.patch added

from Justin Yin (IBM) and the IBM GCoC lab (CCLA)

comment:1 Changed 12 years ago by Adam Peller

(In [8651]) Remove bidi.js. Add 'dir' attribute to Widget.js. Refs #3049

comment:2 Changed 12 years ago by Adam Peller

(In [8666]) Move bidi computedStyle call in postMixInProperties out to an accessor method. Fixes #3073, refs #3049

comment:3 Changed 12 years ago by Adam Peller

(In [9757]) The 3x4 palette dim should be exactly the same as the graphic (important for BiDi?) Refs #3049. Thanks, Justin Yin

comment:4 Changed 12 years ago by Adam Peller

(In [9759]) Add test-bidi switch to tests. Refs #3049

comment:5 Changed 12 years ago by Adam Peller

(In [9763]) ProgressBar? BiDi? fix for FF from Justin Yin, IBM. Refs #3049

Changed 12 years ago by Adam Peller

rtl variations on images from Justin Yin (IBM)

comment:6 Changed 12 years ago by Adam Peller

(In [9797]) First pass at BiDi? patches. Refs #3049

comment:7 Changed 12 years ago by Adam Peller

(In [9799]) TitlePane? text arrows fix for BiDi?. Refs #3049

comment:8 Changed 12 years ago by Douglas Hays

(In [9800]) References #3049. Removed fieldset from template for bidi support.

comment:9 Changed 12 years ago by Douglas Hays

(In [9801]) References #3049. Removed fieldset from Spinner and Combobox template for bidi.

comment:10 Changed 12 years ago by Douglas Hays

(In [9802]) References #3049. Removed fieldset from ComboButton? template for bidi support.

comment:11 Changed 12 years ago by Adam Peller

(In [9827]) More bidi -- inline years so they'll flip in rtl, also switch arrow nodes. Refs #3049

comment:12 Changed 12 years ago by Adam Peller

(In [9830]) Renamed dijitA11y{Left,Right}Arrow classes to dijitA11ySideArrow, since there are no directional issues. Refs #3049. Should these classes even contain "A11y" in their names?

Changed 12 years ago by Adam Peller

BiDi? patches from Justin for Button

Changed 12 years ago by Adam Peller

BiDi?? patches from Justin for Button

Changed 12 years ago by Adam Peller

style BiDi? patches from Justin for Button, Tooltip

Changed 12 years ago by Adam Peller

BiDi?? patches from Justin for Tooltip

comment:13 Changed 12 years ago by Adam Peller

(In [9833]) Apply button and tooltip BiDi? patches. Refs #3049

comment:14 Changed 12 years ago by Adam Peller

(In [9836]) Bidi patch for Menu (thanks, Justin) Refs #3049

comment:15 Changed 12 years ago by Adam Peller

Milestone: 0.91.0

We made good progress for 0.9, but we're not going to finish BiDi? until 1.0. Still remaining: layout widgets, editor, and of course, grid. Perhaps a few others.

comment:16 Changed 12 years ago by Adam Peller

(In [9978]) update tests to include testBidi option. Refs #3049

comment:17 Changed 12 years ago by Adam Peller

(In [9979]) RTL theme change to support BiDi? for AccordionContainer?. Refs #3049

comment:18 Changed 12 years ago by Adam Peller

(In [9981]) Redo BiDi? button patch. Refs #3049, Fixes #3933

comment:19 Changed 12 years ago by Adam Peller

(In [10226]) Add bidi preamble to themnetest. Refs #3049

comment:20 Changed 12 years ago by Adam Peller

Milestone: 1.00.9
Resolution: fixed
Status: newclosed

base bidi patches are done for now, I hope. Will address individual widgets and regressions as separate tickets. Many widgets remain to be BiDi?-enabled, including TabContainer?, Editor, Layout and SplitContainer?...

comment:21 Changed 12 years ago by Adam Peller

Keywords: bidi added

Changed 12 years ago by Adam Peller

update from Evan Huang (IBM)

comment:22 Changed 12 years ago by Adam Peller

(In [12936]) change _isBodyLtr to Widget.isLeftToRight(). Refs #3049 !strict

comment:23 Changed 10 years ago by bill

(In [21091]) Remove some FF workaround code that's no longer needed (probably it was for FF2 but there's no documentation about it), refs #3049 ([9833]), #10570 !strict.

Note: See TracTickets for help on using tickets.