Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2971 closed defect (fixed)

shrinksafe regression

Reported by: alex Owned by: alex
Priority: high Milestone:
Component: BuildTools Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

from Ben Lowery:

Greetings,

For some reason, the compressor bit of the new build system seems to be
turning the following code:

foo.bar = new function(){}();

into

foo.bar = new function(){};();

Is anyone else seeing this or am I going insane?

[8345] introduced this issue.

Change History (2)

comment:1 Changed 13 years ago by alex

Resolution: fixed
Status: newclosed

(In [8508]) fixes #2971. Thanks to Ben Lowery for finding and reporting the issue.

comment:2 Changed 12 years ago by (none)

Milestone: 0.9M2

Milestone 0.9M2 deleted

Note: See TracTickets for help on using tickets.