Opened 12 years ago

Closed 12 years ago

#2956 closed defect (worksforme)

Submenu positioning is incorrect

Reported by: simonjb Owned by: simonjb
Priority: high Milestone: 0.9beta
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by simonjb)

On Firefox 2:

On IE7:

Attachments (2)

Submenus FF.PNG (8.4 KB) - added by simonjb 12 years ago.
Submenus IE7.PNG (5.7 KB) - added by simonjb 12 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by simonjb

Owner: changed from bill to simonjb

Changed 12 years ago by simonjb

Attachment: Submenus FF.PNG added

Changed 12 years ago by simonjb

Attachment: Submenus IE7.PNG added

comment:2 Changed 12 years ago by simonjb

Description: modified (diff)

comment:3 Changed 12 years ago by simonjb

The Firefox positioning was recently corrected by a commit to svn (not by me).

The IE positioning seems to be caused by the menu believing it is in a right-to-left language locale (when it isn't). Currently investigating dijit.util.bidi.isLeftToRight().

comment:4 Changed 12 years ago by simonjb

See #3018

comment:5 Changed 12 years ago by Adam Peller

Component: WidgetsDijit
Resolution: worksforme
Status: newclosed

someone fixed this.

Note: See TracTickets for help on using tickets.