Opened 12 years ago

Closed 12 years ago

#2932 closed defect (worksforme)

Dijit: think about removeChild()/addChild()

Reported by: bill Owned by: Adam Peller
Priority: high Milestone: 0.9
Component: Dijit Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

  1. removeChild()/addChild() (in Container.js) are confusing names because they seem like they refer to adding/removing dom nodes but actually they refer to widgets. Maybe addChildWidget()/removeChildWidget() ?
  1. should removeChild() destroy the child widget, or just detach the child from the parent? If it destroys the child then we should rename it to destroyChild / destroyChildWidget()

This is exposed for stuff like the X key to destroy a tab.

Change History (3)

comment:1 Changed 12 years ago by Adam Peller

Component: GeneralDijit

comment:2 Changed 12 years ago by bill

Milestone: 0.9

removeChild() should just detach, like it does now.

So the only issue is the method names (*Child() vs. *ChildWidget?()). I'm fine with the names as they are. If we did changes the names it would have to be across the board, including stuff like StackContainer::selectChild() etc.

Adam, objections to just closing this?

comment:3 Changed 12 years ago by Adam Peller

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.