Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#2859 closed enhancement (fixed)

Editor2 does not include Jot patches for normalizing line height

Reported by: alex Owned by: liucougar
Priority: high Milestone:
Component: Editor Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

Abe Fettig submitted patches from Jot to normalize line heights between IE and FF w/o adversely affecting the content of the editor. These have not yet been integrated into the main RichText? control. They need to be implemented ASAP.

Change History (6)

comment:1 Changed 12 years ago by liucougar

I think that patch is more about normalizing enter key behavior, rather than line height

I will incoporate that patch and use it if blockNodeForEnter is set to BR, otherwise use existing logic

comment:2 Changed 12 years ago by liucougar

Resolution: fixed
Status: newclosed

(In [8341]) fixes #2859: when blockNodeForEnter="BR" the jot logic will be used (the default)

comment:3 Changed 12 years ago by (none)

Milestone: 0.9M2

Milestone 0.9M2 deleted

comment:4 Changed 11 years ago by bill

(In [15199]) Better comments for EnterKeyHandling? plugin, refs #1331, #2859 !strict

comment:5 Changed 10 years ago by bill

(In [18386]) Attempt to clarify EnterKeyHandling? API documentation, refs #1331, #2859 !strict.

comment:6 Changed 10 years ago by bill

(In [18404]) Code reduction for _fixNewLineBehaviorForIE() (refs #2859), plus fixing IE8 console exception when using BR mode for EnterKeyHandling?, caused by [17924] (refs #9378).

!strict

Note: See TracTickets for help on using tickets.