Opened 12 years ago

Closed 11 years ago

#2855 closed defect (fixed)

dojo.style(node, "cssText", ...) fails on opera

Reported by: bill Owned by: alex
Priority: high Milestone: 1.2
Component: HTML Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

dojo.style(node, "cssText", ...)

will fail on Opera. The Dojo 0.4 copyStyle() function had special code for opera/cssText but the new Dojo 0.9 code doesn't.

Not sure if that's a bug or by design (there are no comments in _base/html.js for dojo.style.

Change History (4)

comment:1 Changed 12 years ago by bill

(In [8313]) Filed bug #2855 that dojo.style("cssText") doesn't work on opera; removed comments from code.

(Refs #2855)

comment:2 Changed 12 years ago by sjmiles

Owner: changed from sjmiles to alex

comment:3 Changed 12 years ago by dylan

Milestone: 1.2

comment:4 Changed 11 years ago by alex

Resolution: fixed
Status: newclosed

(In [14412]) ensure that cssText works as intended. Fixes #2855. !strict

Note: See TracTickets for help on using tickets.