Opened 13 years ago

Closed 12 years ago

#2768 closed defect (wontfix)

M2: 09 D.O.H does not seem to find tests when loaded remotely in Safari.

Reported by: guest Owned by: alex
Priority: high Milestone: 0.9beta
Component: TestFramework Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

M2: 09 D.O.H does not seem to find tests when loaded remotely in Safari.

I've been trying to run the tests across multiple browswers and the like and I've found problems with Safari 2.0.4 on an Intel based MAC. Namely when I connect to a webserver to load the test harness for base, it shows '0' tests. It appears that the loading framework for .js fines doesn't seem to be working quite right with this level of safari when doing remote URL accessing.

As an aside: FireFox? 1.5 works fine Opera 9 Works fine. IE works mostly fine except for failures in xhrGet using tests (trac is already open on this problem).

Change History (4)

comment:1 Changed 13 years ago by guest

Note again, the above was opened by Jared Jurkiewicz

Also, it works fine in webkit. So, if this is just a situation where webkit is the targetted browser and safari 2.0.4 will be unsupported, then this can be disregarded. :)

comment:2 Changed 13 years ago by alex

Hey Jared,

so the problem is the safari doesn't support thing like:

  var thigner = function thinger(){ ... }

whereas webkit does. The test harness works correctly in Safari, but the tests themselves don't.

I'm not sure this is worth fixing since we're expecting to only be supporting Webkit pretty soon after release.

The delay in Leopard gives me some pause, though.

Regards

comment:3 Changed 13 years ago by guest

Alex,

Thanks for the explanation. I'm not hard-pressed on this issue that it needs to work in Safari 2.0.4. That said if you can make it work, that would be awesome (certainly not necessary!). I'm not very familiar with MAC's update strategy, so would webkit be automatically pushed out to all OS-X users more or less when it is officially supported by Apple? In other words, what can we expect the dropoff rate of Safari 2.0.4 to be?

-- Jared

comment:4 Changed 12 years ago by alex

Resolution: wontfix
Status: newclosed

I'm gonna close this one out as "wontfix".

Note: See TracTickets for help on using tickets.