Opened 12 years ago

Closed 12 years ago

#2720 closed defect (wontfix)

Filteringtable multiple select

Reported by: guest Owned by: Tom Trenka
Priority: high Milestone: 0.9
Component: Dijit Version: 0.4.2
Keywords: filteringtable multiple select Cc:
Blocked By: Blocking:

Description

Multiple select in Filteringtable is behaving incorrectly and differs from the way SortableTable? handles multiple select: when "normal" clicking on a row, the row is added to the list of selected rows. The behaviour I expect is:

  • normal click = select only the row clicked on
  • Ctrl+click = add row to selection
  • shift+click = add rows from last selected to currently selected row to selection

The onSelect function only checks if the shiftKey is used, not the ctrlKey...

Change History (2)

comment:1 Changed 12 years ago by bill

Component: WidgetsDijit
Milestone: 0.9
Owner: changed from bill to Tom Trenka

comment:2 Changed 12 years ago by Tom Trenka

Resolution: wontfix
Status: newclosed

This behavior was both by design and request...but....

FilteringTable? is not being ported to either Dijit or DojoX, so I'm closing the bug.

Note: See TracTickets for help on using tickets.