Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2710 closed task (fixed)

port dojo.lfx/animation to 0.9

Reported by: Adam Peller Owned by: Adam Peller
Priority: high Milestone:
Component: lfx Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description


Change History (28)

comment:1 Changed 12 years ago by Adam Peller

(In [7974]) First stab at porting Animation and lfx (fx). Refs #2710

comment:2 Changed 12 years ago by Adam Peller

(In [7975]) Refs #2710

comment:3 Changed 12 years ago by alex

(In [7980]) some reformatting of the fx code to remove use of the dojo._base.fx object. Also enabling it in the default require list for Base. Refs #2710

comment:4 Changed 12 years ago by alex

Adam: great work on getting stuff moved over. Any word on tests?

comment:5 Changed 12 years ago by Adam Peller

(In [8017]) Fix regression in fade animation. Refs #2710

comment:6 Changed 12 years ago by Adam Peller

(In [8026]) Still trying to get unit tests working. Refs #2710

comment:7 Changed 12 years ago by Adam Peller

(In [8027]) Update to use dojo.connect. Refs #2710

comment:8 Changed 12 years ago by Adam Peller

(In [8037]) Fix slideIn/slideOut. Refs #2710

comment:9 Changed 12 years ago by alex

(In [8041]) give this test more breathing room. Refs #2710

comment:10 Changed 12 years ago by Bryan Forbes

(In [8044]) refs #2710

  • Cleaned up some cruft that wasn't used.
  • Changed animateProperty to only accept a list of properties rather than an object with properties defined on it.

comment:11 Changed 12 years ago by Adam Peller

(In [8054]) port dojo.lfx.slideTo, some style changes and reductions. Refs #2710

comment:12 Changed 12 years ago by Bryan Forbes

(In [8055]) refs #2710

  • Removd dojo.fx._Chain and dojo.fx._Combine; removed _IAnimation.
  • Added combine and chain methods on _Animation and combine and chain convenience functions on dojo.fx.
  • Removed polymorphism checks in the constructor of _Animation.

comment:13 Changed 12 years ago by Bryan Forbes

(In [8088]) refs #2710

  • Changed dojo.fx.chain and dojo.fx.combine to work correctly.

comment:14 in reply to:  13 Changed 12 years ago by alex

Replying to BryanForbes:

(In [8088]) refs #2710

  • Changed dojo.fx.chain and dojo.fx.combine to work correctly.

Hey guys,

Glad to see you're making progress on the file-size and API issues, but there aren't accompanying tests.

Please add porting-guide entries and tests at your earliest convenience.

comment:15 Changed 12 years ago by Adam Peller

(In [8133]) Add dojo.fx.wipeIn, add some tests. animate test not yet working. Refs #2710

comment:16 Changed 12 years ago by Bryan Forbes

(In [8147]) refs #2710

  • Removed calculation of the difference between start and end in dojo._Line and PropLine?.
  • Changed dojo._Animation's and dojo.animateProperty's constructors to take one argument that gets mixed into the _Animation object.
  • Changed dojo.animateProperty to not use an intermediate variable (targs) to store information about the property animation.
  • Changed dojo.animateProperty back to using an object (rather than an array of objects) for property values.
  • Removed connection of handlers in dojo._Animation. User will have to connect to events after the creation of the animation.
  • Removed repeat function. This can be set in the constructor now.
  • Changed chain and combine methods to take an array of animations rather than figure it out from arguments.
  • Added a delay property on dojo._Animation that can be overridden in the play method.
  • Changed the _percent property to hold a value between 0 and 1 rather than 1 and 100. This should speed things up a bit since it's not calculating the decimal each time it's used.
  • Changed core fx.js to use the changes listed above.

comment:17 Changed 12 years ago by Bryan Forbes

(In [8158]) refs #2710

  • Changed dojo._Line to only take single values for start and end, rather than an array for both.
  • Changed repeatCount to repeat.
  • Removed some unnecessary intermediate variables.
  • Changed all fx functions to only operate on one node rather than an array of nodes.
  • Changed all fx functions to use one keyword object argument.
  • Uncommented the 3rd fx test.

comment:18 Changed 12 years ago by Adam Peller

(In [8219]) adopt new dojo.fx APIs. Refs #2710, [8158]

comment:19 Changed 12 years ago by Adam Peller

(In [8221]) Refs #2710

comment:20 Changed 12 years ago by Adam Peller

(In [8225]) Missed a dojo.html reference. Refs #2710

comment:21 Changed 12 years ago by Adam Peller

(In [8228]) more fixing up for 0.9. Refs #2710

comment:22 Changed 12 years ago by Adam Peller

(In [8229]) fix wipeOut. Refs #2710

comment:23 Changed 12 years ago by Adam Peller

(In [8244]) wipeIn/Out was renamed to slideIn/Out. Refs #2710

comment:24 Changed 12 years ago by sjmiles

(In [8265]) Repair test by using dojo.marginBox to measure height. Refs #2710.

comment:25 Changed 12 years ago by alex

Resolution: fixed
Status: newclosed

marking closed. New issues should get their own bugs.

comment:26 Changed 12 years ago by alex

(In [8585]) animation isn't useful if we can't manipulate colors. Adds dojo.Color class (completely reworked) and adds support for color animations back into the the Base animation system. Wish it were smaller, but it is what it is. Refs #2710

comment:27 Changed 12 years ago by alex

(In [8683]) remove spurious debugging. Refs #2710

comment:28 Changed 12 years ago by (none)

Milestone: 0.9M2

Milestone 0.9M2 deleted

Note: See TracTickets for help on using tickets.