Opened 12 years ago

Closed 12 years ago

#2707 closed defect (wontfix)

memory leak in dojo charting

Reported by: guest Owned by: Tom Trenka
Priority: high Milestone:
Component: Charting Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I want to implement a monitoring app using dojo charting

I have made a small prototype that updates a chart based on a timeout the app is constantly leaking memory.

pb reproduced with 0.4.2 rc2 on FF2.0 test case attached to the defect.

to reproduce, click on the 'live chart leak' button

You need the fix described in defect 2706 to make the application work

Thanks

Yann

Attachments (1)

chart_leak.html (3.0 KB) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by guest

Attachment: chart_leak.html added

comment:1 Changed 12 years ago by guest

btw feel free to add this test program to the tests delivered with dojo. I think it is actually simpler than the test delivered and useful to help understand the charting api

comment:2 Changed 12 years ago by guest

I have investigated. This fix in the Chart.render() function improves things (but it still leaks...)

if (this.node.firstChild){ this.node.replaceChild(node, this.node.firstChild);

area.render();

}else{

this.node.appendChild(node);

}

comment:3 Changed 12 years ago by Adam Peller

Component: GeneralCharting
Owner: changed from anonymous to Tom Trenka

comment:4 Changed 12 years ago by Tom Trenka

Resolution: wontfix
Status: newclosed

Closing this because the port of charting to DojoX includes a rewrite to base it on the DojoX GFX engine, so that no directly manipulation of nodes will be happening.

Note: See TracTickets for help on using tickets.