Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2665 closed defect (fixed)

DropdownDatePicker renders all dates as NaN

Reported by: Adam Peller Owned by: tk
Priority: high Milestone:
Component: Widgets Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

Karl, sorry if this is a dup or something else that should have been reopened, but a variation of the NaN problem continues in 0.4.2.

From John Zhang (IBM) 1) input a date in the date field, like 2007-03-28; (using zh-cn locale) 2) delete the input value; 3) click the dropdown icon to show the calendar; 4) there are all NaN in the calendar, see attached picture.

You can reproduce this using any dddp with any locale, apparently.

http://download.dojotoolkit.org/release-0.4.2/dojo-0.4.2-widget/tests/widget/test_DropdownDatePicker.html

Select and delete all text in the input field for "Explode", "Fade", or just about any dddp on the page, then hit the dropdown to see the calendar. You'll see all NaN values. For whatever reason, "Wipe" doesn't do this -- perhaps it has something to do with the static nature of that widget.

Attachments (2)

DP+DDP_0.4.2_to_trunk.diff (7.4 KB) - added by tk 13 years ago.
Patch from 0.4.2 DatePicker? to Trunk (0.4.3) fixes several bugs
datepickerPatchedFiles.zip (17.3 KB) - added by tk 13 years ago.
Zipped version of the patch

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by tk

This was confirmed fixed in trunk. I have a patch created from 0.4.2->trunk for the needed files to make an 0.4.3 version of the Datepickers.

Attaching it here so maybe John can try it out, but closing this since it is fixed in trunk.

Changed 13 years ago by tk

Attachment: DP+DDP_0.4.2_to_trunk.diff added

Patch from 0.4.2 DatePicker? to Trunk (0.4.3) fixes several bugs

comment:2 Changed 13 years ago by tk

Resolution: invalid
Status: newclosed

comment:3 Changed 13 years ago by Adam Peller

Resolution: invalid
Status: closedreopened

Let's leave this open until we either apply this to trunk or decide we're not going to. Fair?

Changed 13 years ago by tk

Attachment: datepickerPatchedFiles.zip added

Zipped version of the patch

comment:4 Changed 13 years ago by Adam Peller

tk, could you please check this in the 0.4 branch so we're ready for the next dot release?

comment:5 Changed 13 years ago by Karl Tiedt

Resolution: fixed
Status: reopenedclosed

(In [8684]) fixes #2665 fixes #2674 This fixes 2 very annoying bugs and cleans up a few things.

comment:6 Changed 12 years ago by (none)

Milestone: 0.4.4

Milestone 0.4.4 deleted

Note: See TracTickets for help on using tickets.