Opened 12 years ago

Closed 11 years ago

#2655 closed defect (worksforme)

Multiple requests on form bind (for post method)

Reported by: mknavaneethan@… Owned by: dante
Priority: high Milestone: 1.1
Component: IO Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

I noticed this weird behaviour.

I have a form in a dialog. The first time after the page is loaded or refreshed, when I submit form it's sending the request twice to my POST method. With every subsequent submit the number of requests increases by one (the secnd time I submit, 3 requests are sent, the third time 4 requests are sent and so on ... ).

Thanks, Karthik.

Change History (2)

comment:1 Changed 12 years ago by dylan

Milestone: 0.4.41.1
Owner: changed from alex to dante
Priority: highestnormal
severity: blockernormal

investigate and see if this is still an issue with 1.0.x. I don't think it is, but it should be verified.

comment:2 Changed 11 years ago by dante

Resolution: worksforme
Status: newclosed

I remember the ole' double-submit io.bind() bug, and am unable to reproduce it in any simple test, thought I could just be misunderstanding the setup. please reopen w/ testcase attached against upcoming 1.1 if the problem is found to be true again.

Note: See TracTickets for help on using tickets.