Changes between Version 1 and Version 12 of Ticket #2654


Ignore:
Timestamp:
Jun 15, 2007, 4:01:39 AM (15 years ago)
Author:
bill
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #2654

    • Property Component changed from Widgets to Dijit
    • Property Owner changed from koranteng to mumme
  • Ticket #2654 – Description

    v1 v12  
    1 port ContentPane to the 0.9 dijit codebase.
     1Port ContentPane to Dijit 0.9.  More advanced ContentPane features will go into dojox; dijit will just have a simple ContentPane.
    22
    3 Place in the layout directory along with other layout widgets.
     3Basic features in dijit:
    44
    5 Remove code for CSS mangling and execute-scripts; that will go into dojox eventually.
     5    * href loading
     6    * embedded widgets
    67
     8DojoX enhanced features (not in dijit):
     9
     10    * script loading/execution
     11    * CSS file loading, adjustment of pathnames
     12    * handle (javascript function to generate content)
     13    * regex to parse out stuff in <body> as content, ignore stuff in <head>
     14
     15Removed from both:
     16
     17    * auto-loading of dojo.require() objects
     18
     19Other notes:
     20
     21    * rename setUrl to setHref
     22    * Rename cacheContent -> preventCache
     23    * Consider using a css class with a loading image as background image instead of the Loading.. message that way we don't rely on i18n and it would be prettier in my opinion. The same goes for a error message.