Opened 13 years ago

Closed 13 years ago

#2647 closed defect (duplicate)

Build Process and commented templateCssPath

Reported by: Michael Schall Owned by: alex
Priority: high Milestone:
Component: BuildSystem Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

Build process tries to intern css files even if the templateCssPath is commented out

dojo.widget.defineWidget("judo.widget.InfoBox", judo.widget.Input, {

	//Properties
	widgetType: "InfoBox",
	isContainer: false,
	templateString:  
				'<span>' +
					'<label dojoAttachPoint="label" class="judo_infobox_label"></label>' +
					'<label dojoAttachPoint="input" class="judo_infobox_value"></label>' +
				'</span>',
	//templateCssPath: dojo.uri.dojoUri("../judo/widget/templates/HtmlInfoBox.css"),
	dataType: "",
	...

The build errors:

[java] org.mozilla.javascript.WrappedException?: Wrapped java.io.FileNotFoun?

dException: ....judowidget emplatesHtmlInfoBox.css (The system cannot find the path specified) (../src/hostenv_rhino.js#170)

In my case, I need to remove the code since I have deleted the file, but the build should not include commented out includes.

Thanks

Change History (3)

comment:1 Changed 13 years ago by Michael Schall

It actually looks like it "tries" to intern all widget support files.

I'm not including any of the below files in my profile... The build process tries to intern them.

...
     [java] Interning resource path: ../release/dojo/src/widget/demoEngine/templates/DemoNavigator.css
     [java] Module match: dojo.widget and demoEngine/templates/DemoPane.html
     [java] Interning resource path: ../release/dojo/src/widget/demoEngine/templates/DemoPane.html
     [java] Module match: dojo.widget and demoEngine/templates/DemoPane.css
     [java] Interning resource path: ../release/dojo/src/widget/demoEngine/templates/DemoPane.css
     [java] Module match: dojo.widget and demoEngine/templates/SourcePane.html
     [java] Interning resource path: ../release/dojo/src/widget/demoEngine/templates/SourcePane.html
     [java] Module match: dojo.widget and demoEngine/templates/SourcePane.css
     [java] Interning resource path: ../release/dojo/src/widget/demoEngine/templates/SourcePane.css
     [java] Module match: dojo.widget and templates/Dialog.html
     [java] Interning resource path: ../release/dojo/src/widget/templates/Dialog
.html
...

I have looked through the built dojo.js and I can't find any extra code added, but was surprised to see the build even trying to include the files.

comment:2 Changed 13 years ago by James Burke

You will see the "interning resource path" messages in a build even if you do not have templates in dojo.js -- it is processing the widget files in the src/ directory. That is the source of those messages.

comment:3 Changed 13 years ago by James Burke

Resolution: duplicate
Status: newclosed

Closing this bug as a dupe of #2429.

Note: See TracTickets for help on using tickets.