Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2635 closed defect (worksforme)

DropDownContainer throws 'no properties' exception

Reported by: guest Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

DropDownContainer? throws 'no properties' exception 'record has no properties'

to reproduce this bug, just run 'test_DropDownContainer.html'

firebug shows the following:

getTagName(undefined)dojo.js (line 124) (no name)(undefined,null,true,undefined)dojo (line 184) makeWidgets() dojo.js (line 910) (no name)()dojo (line 919) loaded()dojo.js (line 239) callLoaded()dojo.js (line 295) moduleLoaded()dojo.js (line 288) dj_load_init(load ) dojo.js (line 849) [Break on this error] record, status) {this.pr.GPR_resolvedIp=record.getNextAddrAsString()};BTB_PageRank...} toolbar.js (line 439)

Change History (4)

comment:1 Changed 12 years ago by James Burke

Can you provide more info? Was this on the trunk or in the 0.4.2 release? Were you using a custom build? A web build? What browser were you using?

I just tried this URL: http://download.dojotoolkit.org/release-0.4.2/dojo-0.4.2-ajax/tests/widget/test_DropdownContainer.html

and it worked fine in Firefox 2.0.0.3 on OS X.

comment:2 Changed 12 years ago by guest

Just for info (I have not posted the original bug report): You need to install the Firebug add-on for Firefox to see that error: http://www.getfirebug.com

I believe it's a problem in Firebug since I have the same problem in a JavaScript? file I've written unrelated to Dojo.

comment:3 Changed 12 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

comment:4 Changed 12 years ago by guest

I'm seeing the same error, but it's actually raised by the Google Toolbar - toolbar.js line 439 is part of the Google Toolbar extension. So, not a bug in dojo.

Note: See TracTickets for help on using tickets.