Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#261 closed defect (worksforme)

IE crashes when adding dojo.debug to SplitPane.js onResized handler

Reported by: M4g3 Owned by: anonymous
Priority: high Milestone:
Component: Widgets Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

When I try and add a dojo.debug message to the onResized handler in SplitPane?.js the cpu usage jumps to 100% and the window becomes unresponsive.

Adding it to another handler or somewhere else in my page works fine. FireFox? 1.5 works fine as well.

I attached my version of SplitPane?.js (added "dojo.debug('a');" after line 77) and the page I used to test (copied from the unit tests)

Attachments (2)

test.html (956 bytes) - added by anonymous 14 years ago.
SplitPane.js (12.9 KB) - added by anonymous 14 years ago.

Download all attachments as: .zip

Change History (6)

Changed 14 years ago by anonymous

Attachment: test.html added

Changed 14 years ago by anonymous

Attachment: SplitPane.js added

comment:1 Changed 14 years ago by alex

Milestone: 0.3release

comment:2 Changed 14 years ago by bill

Yeah, I've seen this. Printing to the screen causes a resize event, which effectively causes onResized() to be called in an endless loop. Hopefully we can be more intelligent about detecting whether things have _really_ been resized or not.

comment:3 Changed 14 years ago by bill

Resolution: worksforme
Status: newclosed

Actually my statement above refers to when you the debug statements increase the length of the page (when the page is longer than the viewport). I tried your testcase and couldn't reproduce. Does it happen w/the newest code? Does it happen when you are acessing dojo via file:// rather than http://? That's what I tried and it worked for me.

comment:4 Changed 13 years ago by (none)

Milestone: 0.3release

Milestone 0.3release deleted

Note: See TracTickets for help on using tickets.