Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2606 closed defect (fixed)

build process does not strip dojo.requireIf statements

Reported by: James Burke Owned by: James Burke
Priority: high Milestone:
Component: BuildSystem Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

This happens in 0.4.2.

Steps to reproduce:

  • Build dojo using the buildscripts/profiles/charting.profile.js profile.
  • After the build is done, open tests/charting/test_engine.html
  • Look at the Firebug console. You will see some requests for some svg modules, but they are already included in dojo.js.

The build process should be removing dojo.requireIf() calls if the module that is referenced by the dojo.requireIf() call is in the built dojo.js.

Change History (9)

comment:1 Changed 13 years ago by James Burke

Milestone: 0.9M1

comment:2 Changed 13 years ago by James Burke

Resolution: fixed
Status: newclosed

(In [7629]) Fixes #2606, dojo.requireIf calls not being stripped from built dojo.js

comment:3 Changed 13 years ago by James Burke

Resolution: fixed

(In [7630]) (merge from 0.4 branch) Fixes #2606, dojo.requireIf calls not being stripped from built dojo.js

comment:4 Changed 13 years ago by James Burke

Milestone: 0.9M10.4.3

comment:5 Changed 13 years ago by James Burke

Resolution: fixed
Status: closedreopened

Reopening -- this change is too aggressive: it seems to be removing all requireIf statements, but it should only remove the ones for modules that are in the built file.

comment:6 Changed 13 years ago by James Burke

Resolution: fixed
Status: reopenedclosed

(In [8071]) Fixes #2606. Forgot to escape regexp sensitive characters in the dependency string.

comment:7 Changed 13 years ago by James Burke

Resolution: fixed

(In [8072]) (merge from 0.4 branch) Fixes #2606. Forgot to escape regexp sensitive characters in the dependency string.

comment:8 Changed 13 years ago by James Burke

Resolution: fixed

(In [8073]) (merge from 0.4 branch) Fixes #2606. Forgot to escape regexp sensitive characters in the dependency string.

comment:9 Changed 12 years ago by (none)

Milestone: 0.4.3

Milestone 0.4.3 deleted

Note: See TracTickets for help on using tickets.