Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#257 closed defect (worksforme)

dojo causes IE close problem when page contains a combo box

Reported by: sheilao@… Owned by: alex
Priority: high Milestone:
Component: Widgets Version: 0.2
Keywords: combo box IE memory violation Cc:
Blocked By: Blocking:

Description (last modified by alex)

When trying to use dojo to populate a combo box, IE version 6 gives a memory violation when the window is closed

Reduced my page to a simple combo box

if i simply open the page and close the window - IE exits normally If i open the page, change the value in the combo, and then close the window, IE gives memory violation message

This is my test page - if i remove dojo.js IE gives no problem

<html>
<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<script type="text/javascript" src="dojo/dojo.js"></script>
</head>

<body bgcolor="#FFFFFF" text="#000000">
<form name="form1" method="post" action="">
  <select name="select">
    <option value="1">h</option>
    <option value="2">nn</option>
    <option value="3">nnnn</option>
  </select>
</form>
</body>
</html>

Change History (7)

comment:1 Changed 13 years ago by anonymous

severity: normalcritical

comment:2 Changed 13 years ago by alex

Component: CoreWidgets
Description: modified (diff)
Milestone: 0.3release
Priority: highesthigh
severity: criticalnormal

comment:3 Changed 13 years ago by anonymous

Milestone: 0.3release0.2.1release
Status: newassigned

comment:4 Changed 13 years ago by alex

Owner: changed from anonymous to alex
Status: assignednew

comment:5 Changed 13 years ago by alex

Resolution: worksforme
Status: newclosed

I cannot reproduce on IE 6.0.2900 from Windows XP SP2 with the Ajax profile build from Dojo 0.2.0. The kitchen sink build throws an error identical to that reported (and fixed) in [254]. I'll need a reproducible test case in order to consider.

comment:6 Changed 13 years ago by anonymous

confirmed as closed/works for me/invalid/whatever, also on IE 6, XP, SP2, from svn head, r2553

comment:7 Changed 12 years ago by (none)

Milestone: 0.2.1release

Milestone 0.2.1release deleted

Note: See TracTickets for help on using tickets.