Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2569 closed defect (wontfix)

creating InlineEditBox using 'first' position doesn't hide original text properly

Reported by: guest Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description

If you create an InlineEditBox? using the additional position argument to createWidget will cause the following erroneous behavior. When the text is clicked on, the widget appears and behaves properly, except that the original text is displayed immediately after widget.

Looking at the generated HTML, you can see that it creates the widget _and_ the span with display:none with the original text. That's good. But immediately after that is the original text again...

Attached code demonstrates.

Attachments (1)

inlinetest.html (1.2 KB) - added by guest 13 years ago.

Download all attachments as: .zip

Change History (8)

Changed 13 years ago by guest

Attachment: inlinetest.html added

comment:1 Changed 13 years ago by guest

One correction to bug report: when the widget first appears (not just when clicked on0 it is inserted before the original text, rather than replacing it. The expected behavior is that the original text should be replaced by the clickable widget...

for further bug report info please contact: jeffg@…

comment:2 Changed 13 years ago by alex

Resolution: invalid
Status: newclosed

if you want the widget to replace the node in question, just drop the placement argument. It's functioning as expected.

comment:3 Changed 13 years ago by guest

Resolution: invalid
Status: closedreopened

No you have it wrong (I think). I need to use "first" and it doesn't work as shown by the code I attached. I don't want to replace the node... I need to use "first" so that the position of the InlineEditBox? is correct (remains in the same place), because if I don't use "first" then the element moves somewhere else (below element that contains the element I'm supplanting with the inlineEditBox. I did not show that in the code I supplied, but if you have a large element with a subelement positioned within it (absolute coords), and then create an inlineEditBox with the default arguments, as you suggest, you will see that the inlineEditBox appears below.

Not that all the tests for inlineEditBox do not try this!

And using "first" definitely does _NOT_ work as my code shows? You did try it right and it definitely doesn't work correctly.

jeffrey / jeffg@…

comment:4 Changed 13 years ago by guest

correction: The line reading: "Not that all the..." is garbled. It should start with: "Note:" rather than "Not"

Currently no test in dojo tests the inlineEditBox as I describe above... validating where an inlineEditBox appears when supplanting a precisely positioned child node within another larger (parent) element. It does not seem to work properly for me. I can supply a test case if you need me to.

comment:5 Changed 13 years ago by alex

Milestone: 0.4.20.4.3

comment:6 Changed 12 years ago by bill

Resolution: wontfix
Status: reopenedclosed

createWidget() itself is no longer supported, so we won't fix this bug.

comment:7 Changed 12 years ago by (none)

Milestone: 0.4.4

Milestone 0.4.4 deleted

Note: See TracTickets for help on using tickets.