Opened 12 years ago

Closed 6 years ago

#2481 closed defect (wontfix)

dojo.undo.browser: Expand Opera and Safari support

Reported by: James Burke Owned by: Ben Lowery
Priority: high Milestone: future
Component: Core Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by dylan)

Safari: It may be possible to support bookmarking in Safari with dojo.undo.browser and maintain browser history by using a form to submit the URL change. Investigate.

Opera: Opera 9 seems to be able to work with the dojo.undo.browser code. Here are some testing results from Ilia:

Opera 9.10


dojo/tests/undo/test_browser.html

back/forward buttons seem to work...

dojo/tests/undo/test_browser_bookmark.html

bookmarking works, back-forward doesn't work

Konqueror (KDE 3.5.6)


same as Opera 9.10

Change History (10)

comment:1 Changed 12 years ago by Adam Peller

Owner: changed from James Burke to Ben Lowery

comment:2 Changed 12 years ago by bill

Milestone: 0.91.1

comment:3 Changed 12 years ago by Ben Lowery

It appears that Opera latest (9.22 as of now) has a problem stopping timers set using setInterval when the user hits back or forward to move from hash to hash. This is a showstopper on Opera for now. Going to investigate other ways (setTimeout?) of detecting hash changes.

Opera does resume the interval timer once the user presses a key in the page somewhere. Might be worth reporting a bug to the Opera folks to see if this is intended behavior.

comment:4 Changed 12 years ago by Ben Lowery

Oh, and Safari3, at least version 3.0.3 (522.12.1) on Mac, seems to work now.

comment:5 Changed 11 years ago by bill

Milestone: 1.11.2

Move all milestone 1.1 tickets to 1.2, except for reopened tickets and tickets opened after 1.1RC1 was released.

comment:6 Changed 11 years ago by dylan

Description: modified (diff)

Moving undo/back bugs to future until Ben or someone else has time to tackle them.

comment:7 Changed 11 years ago by dylan

Milestone: 1.2future

comment:8 Changed 6 years ago by dylan

Resolution: fixed
Status: newclosed

dojo.undo isn't a thing in modern dojo, dojo.back is deprecated, and between dojo/hash and dojo/router we think this is covered, so closing as wontfix.

comment:9 Changed 6 years ago by bill

Resolution: fixed
Status: closedreopened

comment:10 Changed 6 years ago by bill

Component: GeneralCore
Resolution: wontfix
Status: reopenedclosed
Note: See TracTickets for help on using tickets.