Opened 13 years ago

Closed 13 years ago

#2472 closed defect (fixed)

FloatingPane with shadow effects are broken

Reported by: koranteng Owned by: koranteng
Priority: high Milestone: 0.9
Component: General Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

load the floating pane test

http://archive.dojotoolkit.org/nightly/tests/widget/test_FloatingPane.html

  1. Notice that all floating panes that should have shadows (hasShadow set to true) instead have visible scrollbars
  1. any resize handles that should be displayed are hidden by the scrollbars
  1. the rightmost icon (if any) is obscured by the scrollbar

This is a regression from 0.4.1 and is caused by the fix for #1950 in which the overflow for dojoLayoutContainer is set to hidden.

Specifically the shadow effect depends on overflow being visible (see dojoFloatingPane in FloatingPane?.css). This is overriden by what is set on LayoutContainer?.

Change History (1)

comment:1 Changed 13 years ago by bill

Resolution: fixed
Status: newclosed

(In [7445]) Set the overflow to visible if using a drop shadow. Fixes #2472. Patch from Koranteng (IBM, CCLA on file)

Note: See TracTickets for help on using tickets.