Opened 12 years ago

Closed 12 years ago

#2467 closed enhancement (wontfix)

Loading JSON/JavaScript content in IframeIO.js

Reported by: mike@… Owned by: James Burke
Priority: high Milestone: 0.9
Component: IO Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description

The following patch changes the way JSON results are handled in IframeIO bind operations. If the response from the server is plain text Javascript text, without being placed in a <textarea> element, then this method will fall back to using the text content returned from the server. So far only tested under Firefox, but I can test further one IE once I get off of holiday.

Attachments (1)

dojo-IframeIO-json.patch (860 bytes) - added by mike@… 12 years ago.
Original patch

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by mike@…

Attachment: dojo-IframeIO-json.patch added

Original patch

comment:1 Changed 12 years ago by James Burke

Milestone: 0.9
Owner: changed from alex to James Burke

IIRC, the problem is that returning just straight text does not trigger an iframe load event in Safari. It must be a an HTML file to trigger the load. If you can verify that this patch works in IE 6 and 7, Safari 2.0.4 and Opera 9, then we can consider it. (I'm also assuming you've signed and sent in the Dojo Foundation CLA agreement (http://dojotoolkit.org/icla.txt).

comment:2 Changed 12 years ago by James Burke

Resolution: wontfix
Status: newclosed

Closing for now, since I did not get confirmation about the CLA or the testing results in other browsers. Feel free to reopen if there is new info.

Note: See TracTickets for help on using tickets.