Opened 13 years ago

Closed 12 years ago

#2464 closed defect (fixed)

dojo.gfx IE VML rendering incorrect

Reported by: konrads.smelkovs@… Owned by: Eugene Lazutkin
Priority: high Milestone:
Component: gfx (svg+vml) Version: 0.4.1
Keywords: gfx, vml, ie6, ie7 Cc:
Blocked By: Blocking:

Description

The bug can be best viewed when comparing FF/Opera output versus Internet Explorer output. I have not built a sample test case, but have a live example of where it doesn't work. Steps to reproduce:

  • Click "Kwidge Back"
  • Click balloon icon. The textarea in it and the balloon are aligned.

Repeat same with IE and it is visible, that alignment is out of order.

I think the cause is the method how VML is positioned - using css. It either disregards or inherits some properties that cause the shift.

Change History (2)

comment:1 Changed 13 years ago by guest

I have identified a test case: It seems that having a DTD XHTML, IE renders pages differently from the regular tag soup mode or such. In other words with this as DTD, rendering is "incorrect": <!DOCTYPE html

PUBLIC "-W3CDTD XHTML 1.0 StrictEN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

comment:2 Changed 12 years ago by Eugene Lazutkin

Resolution: fixed
Status: newclosed

It was supposed to be fixed some time ago. Please retest the trunk, and reopen, if you still have a problem.

Note: See TracTickets for help on using tickets.