Opened 13 years ago

Closed 13 years ago

#2454 closed defect (worksforme)

progress bar startAnimation() doesn't show anything

Reported by: guest Owned by: Adam Peller
Priority: high Milestone:
Component: Widgets Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description

in dojo.widget.ProgressBar?.js, the internalProgress object which allows to show the animation has a 0 size at the second start. Had do modify the source like that :

startAnimation: function(){

if (this._animationStopped) {

this._backupValues(); this.setProgressValue("10%"); this._animationStopped = false; this._setupAnimation(); this.showText(false); this.internalProgress.style.height="105%"; ADDED this.internalProgress.style.width="30px"; this._animation.play();

}

},

and put the left size in a hard value :

_setupAnimation: function(){

var _self = this; dojo.debug("internalProgress width: " + this.internalProgress.style.width); this._animation = dojo.lfx.html.slideTo(this.internalProgress,

{top: 0, left: 770}, parseInt(this.duration), null,

to see something moving !

Change History (5)

comment:1 Changed 13 years ago by guest

it is a walk around of the #2433 issue actually ( I thought it has been deleted as I don't see it in http://trac.dojotoolkit.org/report/1 )

comment:2 Changed 13 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

Unable to reproduce using the new dijit.ProgressBar?, or perhaps I don't understand correctly. dijit/tests/test_ProgressBar has a "start" button which calls startAnimation() and that seems to work. If the problem only exists in dojo.widget.ProgressBar?, we can consider this fixed as that code will be removed.

comment:3 Changed 13 years ago by Adam Peller

Resolution: worksforme
Status: closedreopened

comment:4 Changed 13 years ago by Adam Peller

Owner: changed from lots of people to Adam Peller
Status: reopenednew

comment:5 Changed 13 years ago by Adam Peller

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.