Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2426 closed defect (invalid)

Browser Storage bug - dojo.storage.browser not defined

Reported by: shaneosullivan1@… Owned by: bradneuberg
Priority: high Milestone:
Component: Storage/Flash Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description

There is a bug in the dojo.storage package, where in the dojo/src/storage/browser.js file it attempts to create the dojo.storage.browser.FileStorageProvider object without first creating the dojo.storage.browser object.

The storage therefore breaks a Dojo build if it is included, and causes errors on a page if the script is included directly.

A patch to fix this is available at http://www.skynet.ie/~sos/misc/BrowserStorage.patch

Attachments (1)

BrowserStorage.patch (816 bytes) - added by shaneosullivan1@… 13 years ago.
Attaching the patch required to fix this bug. CLA filed under Cúram Software.

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by shaneosullivan1@…

Attachment: BrowserStorage.patch added

Attaching the patch required to fix this bug. CLA filed under Cúram Software.

comment:1 Changed 13 years ago by bradneuberg

Component: GeneralStorage/Flash
Owner: changed from anonymous to bradneuberg

I'm planning to rip out the FileStorageProvider?. Shane, are you using this provider? My plan is to remove it and place it as a patch that folks can apply, since I don't think it is a very common used provider and I want to reduce bloat.

comment:2 Changed 13 years ago by shaneosullivan1@…

Brad,

Yes, I was using the FileStorageProvider?, but it turns out that upon extra investigation that the bug was in my own code. The dojo.provide("dojo.storage.browser") takes care of instantiating the dojo.storage.browser object, so you can close this ticket as not a bug.

Shane

comment:3 Changed 13 years ago by alex

Resolution: invalid
Status: newclosed

comment:4 Changed 12 years ago by (none)

Milestone: 0.4.2

Milestone 0.4.2 deleted

Note: See TracTickets for help on using tickets.