Opened 12 years ago

Closed 12 years ago

#2383 closed defect (invalid)

dojo.byId can't find specific id'd forms in IE7

Reported by: ialpert@… Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description

This seems to be IE7's mess up. and also doesn't work several ids: 5-dialog-form CANADA-dialog-form

however 1234-dialog-form does work

I'll post the test case in a second

Attachments (1)

test_byIdFrom.html (1.0 KB) - added by Izaak Alpert 12 years ago.
IE7 problem

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Izaak Alpert

Attachment: test_byIdFrom.html added

IE7 problem

comment:1 Changed 12 years ago by Izaak Alpert

This seems too obvious a breakage to me, i apologize in advance if I'm doing something stupid. By fussing around with parts of dojo.byId it seems the problem is that IE is reporting that it has no elements in document.all that have this id (despite the element it returns with document.getElementById() being the correct one (without the correct id))

comment:2 Changed 12 years ago by nicola.rizzo+dojo@…

Put your js code in a function and use dojo.addOnLoad(yourFunction).
Everything will work fine.

Nicola

comment:3 Changed 12 years ago by bill

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.