Opened 13 years ago

Closed 13 years ago

#2368 closed defect (invalid)

when FilteringTable is created dynamically, heading cells are <td>, they should be <th>

Reported by: yh_mailinglist@… Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Tom Trenka)

Hello Dojo team,

I have found a small bug, but it is annoying for the css rules

pb reproduced with nightly build.

to reproduce, start the example test_FilteringTable_programmatic.html and inspect the dom with firebug

you get sthg like <table><thead><tr><td> it should be <th>

Thanks

Yann

Change History (1)

comment:1 Changed 13 years ago by Tom Trenka

Description: modified (diff)
Resolution: invalid
Status: newclosed

This is not a bug, it's a "feature". Seriously though, your rules should be applied to either td or th elements that are children of the thead element as opposed to assuming that they will be th elements.

Note: See TracTickets for help on using tickets.