Opened 13 years ago

Closed 12 years ago

#2331 closed enhancement (fixed)

Dojo Compressor - can we have an option to NOT normalize utf-8 encoded data to unicode escape sequences?

Reported by: daniel Owned by: alex
Priority: high Milestone: 1.0
Component: ShrinkSafe Version: 0.4.1
Keywords: Cc: jkuhnert
Blocked By: Blocking:

Description

I'm working with some utf-8 data and the data is stored in js files, as Array values. When I compress the file using dojo compressor, the input characters become unicode escape sequences.

So the example file contains var chars = new Array('À');

and the result of the compression is var chars=new Array("u0102x80");

while I would like to be var chars=new Array("À");

Can we have some compressor option to NOT touch the original encoding and to not normalize user's data? I tried different things, including -Dfile.encoding=utf-8 or using native2ascii tool, but I can't find any reliable solution...

Thank you

Change History (11)

comment:1 Changed 13 years ago by Adam Peller

Component: GeneralBuildTools
Owner: changed from anonymous to alex

comment:2 Changed 13 years ago by alex

Milestone: 0.9beta
severity: normalmajor
Status: newassigned

comment:3 Changed 13 years ago by alex

Priority: normalhigh

comment:4 Changed 12 years ago by James Burke

Milestone: 0.9beta0.9

Moving to 0.9. This issue is in 0.4.x too, and it should not block the 0.9 beta (confirmed with Alex).

comment:5 Changed 12 years ago by jkuhnert

Cc: jkuhnert added

comment:6 Changed 12 years ago by alex

Resolution: fixed
Status: assignedclosed

(In [10070]) prevent shrinksafe from escaping unicode chars. Fixes #2331

comment:7 Changed 12 years ago by guest

Resolution: fixed
Status: closedreopened

I'm sorry, but where is the fixed custom_rhino.jar file that includes the fix? The one from trunk is not fixed, the one from download section under 0.9 is not fixed, I've tried some other files too, from branches etc. Nothing seems to work... Can you point me to the fixed file, or I should build it myslef with the provided diff? (I hope not). THANKS.

comment:8 Changed 12 years ago by James Burke

Milestone: 0.91.0

comment:9 Changed 12 years ago by Adam Peller

Component: BuildToolsShrinkSafe

comment:10 Changed 12 years ago by jkuhnert

hey wait.,....I just looked at the change set - [10070]- and it looks like Alex did update the js.jar file - so is this ticket still really valid anymore?

comment:11 Changed 12 years ago by alex

Resolution: fixed
Status: reopenedclosed

(In [10922]) ensure that we're UTF-8 end-to-end. Fixes #2440. Fixes #4712. Fixes #2331

Note: See TracTickets for help on using tickets.