Opened 13 years ago

Closed 13 years ago

#2323 closed defect (worksforme)

Failure to build i18n resources in external namespace widget

Reported by: Adam Peller Owned by: Adam Peller
Priority: high Milestone: 0.9
Component: BuildSystem Version: 0.4.1
Keywords: Cc: forzhu@…
Blocked By: Blocking:

Description (last modified by dylan)

I have created a customized widget with i18n support. The folder structure of the widget is like:

js
  dojo
     ...
  mycompany
        widgets     (This folder  contains a mywidget.js  file)
              
ls
                 en
                 fr
                 ...

The widget and its i18n mechanism works fine, then I tried to make a build that incorporate the widget.

The build profile is like:

var dependencies = [
   ...
   "mycompany.widget.MyWidget"
];

dependencies.prefixes = [
  ["mycompany", "../mycompany"]
];

load("getDependencyList.js");

The build process looks success and generate no error messages.

I found the i18n messages of the widget is not merged into the nls files beneath dojo/nls folder.

The problem is, when opening the html file in the browser that invoke mywidget, an error message of "no loaded module named ' mycompany.widget.nls.MyWidget?' " appears, and the widget will not be rendered.

Change History (3)

comment:1 Changed 13 years ago by dylan

Description: modified (diff)
Milestone: 0.9

comment:2 Changed 13 years ago by guest

Why are all the build-related issues scheduled for 0.9. In my opinion they are way more important.

Just curious.

comment:3 Changed 13 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

I'm unable to reproduce a problem here. I know it's difficult, but it sounds like I'd need some sample code and a list of steps to find out what's going wrong for you. Please contact me and we'll work together to figure out what's wrong here.

Note: See TracTickets for help on using tickets.