Opened 13 years ago

Closed 12 years ago

#2321 closed defect (fixed)

problem with compressed dojo.js and lfx.wipes functions - wiped elem gains height

Reported by: admin@… Owned by: Bryan Forbes
Priority: blocker Milestone: 0.9
Component: lfx Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description

anyone else noticed that when using dojo.lfx.html.wipe functions after wipes the wiped divs are gaining height ? 2px per wipe , so the wiped elem gets bigger and bigger. it doesnt occur in dojo.js.uncompressed.js .

Change History (5)

comment:1 Changed 13 years ago by alex

Milestone: 0.4.20.9

I cannot reproduce using the wipes test page on FF but it does appear on IE. I don't think we'll have a patch in time for 0.4.2. Bumping to 0.9.

comment:2 Changed 13 years ago by r.j.coon@…

I am reproducing this in FF; it appears to happen with elements with borders. My guess is the wipeIn should be using getContentBox() not getBorderBox() to determine the target height.

comment:3 Changed 13 years ago by jwiltshire@…

I believe that I just raised the same issue as this. Take a look at http://trac.dojotoolkit.org/ticket/2489

The issue is caused by the compressor messing up a local var contained in a 'with' block. A test case and patch are provided in ticket 2489.

I did a search before raising the issue, but missed this ticket.

Any chance we could get this fixed for 0.4.2? It looks (to me at least) to be a very low impact change.

comment:4 Changed 13 years ago by ilia

That looks like bad bad compressor bug... Explains some issues I had.

Compressor can't know what would be the real scope of variable inside with() { ... }, so the only solution seems to ignore variables if they appear inside with() { ... }.

comment:5 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

OK, this is fixed in 0.9 because it always wipes in / out to the natural height of the element.

Note: See TracTickets for help on using tickets.