Opened 13 years ago

Closed 12 years ago

#2303 closed defect (fixed)

JsonRequest don't timeout and possibly hang IE

Reported by: antti@… Owned by: Dustin Machi
Priority: high Milestone: 0.9
Component: RPC Version: 0.4.1
Keywords: Cc: antti@…
Blocked By: Blocking:

Description

It is not possible to define the timeoutSeconds parameter for the JsonRequest? binds.

It would be nice to be able to define this either in the SMD or when making the call.

I'm not sure if this is the root cause but for some reason IEs seem to hang for certain domain randomly for us (probably due to some requests failing somehow but not being cleaned up, causing host-based connection limit to fill up) when issuing json-rpc calls repetitively (once every 15 seconds for us). Thehang can be resolved only by closing all IE windows.

Any tips on other causes for this would also be very welcome.

Change History (2)

comment:1 Changed 13 years ago by dylan

Milestone: 0.9

comment:2 Changed 12 years ago by Dustin Machi

Resolution: fixed
Status: newclosed

(In [8564]) port rpc to 0.9 and fix some other tickets along the way, fixes #2750 , fixes #2303 , fixes #2185 , refs #2915. There is still a json serialization bug, but its almost done

Note: See TracTickets for help on using tickets.