Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#23 closed defect (worksforme)

dojo.event.connect bug

Reported by: antman Owned by: alex
Priority: high Milestone:
Component: Core Version: 0.0
Keywords: Cc: antman@…, alex@…
Blocked By: Blocking:

Description

This doesn't work:

dojo.event.connect(create, "onclick", this, "createSticky");

Had to change it to this to make it work:

dojo.event.connect(create, "onclick", function() {

_this.createSticky();

});

Attachments (1)

test_23.html (835 bytes) - added by alex 14 years ago.
test file that isn't duplicating the error on HEAD for me

Download all attachments as: .zip

Change History (6)

comment:1 Changed 14 years ago by alex

Cc: antman@… alex@… added

just to clarify, the "create" variable here is a DOM node?

comment:2 Changed 14 years ago by alex

Milestone: 0.1release

comment:3 Changed 14 years ago by schontz@…

Version: 0.0

Changed 14 years ago by alex

Attachment: test_23.html added

test file that isn't duplicating the error on HEAD for me

comment:4 Changed 14 years ago by alex

Resolution: worksforme
Status: newclosed

I cannot reproduce the bug with the attached test file on IE, Moz, or Safari. Marking "worksforme".

comment:5 Changed 12 years ago by (none)

Milestone: 0.1release

Milestone 0.1release deleted

Note: See TracTickets for help on using tickets.