Opened 13 years ago

Closed 13 years ago

#2287 closed defect (duplicate)

dojo.io.bind with mimetype: "text/javascript" dose not work in IE

Reported by: ewilde@… Owned by: alex
Priority: high Milestone: 0.9
Component: IO Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description

it seems like that the script is indeed executed, but not in the global scope.

for testing example, i passed the following script:

var a1=[1,1];
alert(a1);

i have got the alert-box as expected, but it failed in the load function:

dojo.io.bind({
...
load: function(type, evaldObj){
  alert(a1); // exception raised !!
},
...

i suspect that in IE we should use execScript(), and not eval(). (eventually, in IE my workaround was using execScript with mimetype: "text/javascript")

Best regards, ewilde.

Change History (1)

comment:1 Changed 13 years ago by James Burke

Milestone: 0.5
Resolution: duplicate
Status: newclosed

Closing as a duplicate of #744.

Note: See TracTickets for help on using tickets.