Opened 13 years ago

Closed 13 years ago

#2270 closed defect (wontfix)

Error creating Tooltip for TreeNodeV3

Reported by: marcel_p@… Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.4.1
Keywords: Tooltip Cc:
Blocked By: Blocking:

Description

I'm trying to create and hook the Tooltip widget to TreeNodeV3 using the latest Dojo 0.4.1 toolkit. The Tree (dojo.widget.TreeV3) and all its nodes (dojo.widget.TreeNodeV3) are created/instantiated programmatically in runtime. Basically everything but the Tooltip work fine. The problem is that Tooltip widget cannot connect to the Tree node widget (specified by ID that is assigned to connectId property of Tooltip widget) and the following error message is reported:

"bad srcObj for srcFunc: onmouseover"

The similar problem was already discussed here: http://www.nabble.com/Re:-dojo.byId()-and-document.getElementById()-issue-p3671674.html

When I implemented the "patch" suggested in discussion mentioned above in Tooltip.js file, then it worked for me. Here is the line of code I inserted in Tooltip.js file, in "fillInTemplate" method right after the line "this._connectNode = dojo.byId(this.connectId);":

if (this._connectNode == null) this._connectNode = dojo.widget.byId(this.connectId).domNode;

Additional info: 1.) Version of Dojo and build name: 0.4.1 (6824) 2.) Browser versions and platforms: MSIE 6.0 with SP2 on WinXP Home Edition 3.) Error message: "bad srcObj for srcFunc: onmouseover" 4.) A contact address: marcel_p@…

Change History (2)

comment:1 Changed 13 years ago by guest

I'm also having this problem. The provided patch works for IE but *doesn't* work for Firefox 2.0.0.3 on Windows XP.

I am using widgets via HTML, no programmatic javascript other than declaring the dojo.widgets at the top of the file.

FATAL exception raised: bad srcObj for srcFunc: onmouseover DEBUG: dojo.widget.Parse: error: [Error: bad srcObj for srcFunc: onmouseover, file: libs/dojo/dojo.js, line: 96]

comment:2 Changed 13 years ago by bill

Resolution: wontfix
Status: newclosed

The Tree code has been completely redone; you can't really set tooltips for tree nodes anymore, because you don't create them directly.

Note: See TracTickets for help on using tickets.