Opened 13 years ago

Closed 13 years ago

#2269 closed defect (fixed)

japanese calendar should start on sunday

Reported by: bill Owned by: Adam Peller
Priority: high Milestone: 0.9
Component: Internationalization Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

See test_D

Change History (3)

comment:1 Changed 13 years ago by Adam Peller

Bill -

Can you tell me what locale your browser is reporting?

navigator.language or navigator.userLanguage for IE

I think the problem is that the country is not specified (e.g. ja instead of ja-JP) I need to account for this.

comment:2 Changed 13 years ago by bill

Description: modified (diff)

Sorry my description before was vague. I think you are right, about what the problem is.

I was on English OS but looking at test_DropdownDatePicker.html, where the "In Japanese" calendar starts on Monday. However the "ja-jp" locale in test_DatePicker.html is working correctly, displaying Sunday first.

On my Japanese machine, running IE7, navigator.userLanguage is "ja" and the problem occurs. (That machine might be weird though because I downloaded IE7 in English)

comment:3 Changed 13 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [7461]) Fixes #2269

Note: See TracTickets for help on using tickets.