Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2242 closed defect (worksforme)

dojotoolkit.org not working on IE v6.0.2900.2180.xpsp_sp2_gdr.050301-1519

Reported by: kathyhkchan-dojo@… Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.4.1
Keywords: Cc: kathyhkchan-dojo@…
Blocked By: Blocking:

Description

I tried to access dojotoolkit.org website with IE v6.0.2900.2180.xpsp_sp2_gdr.050301-1519. The following two errors were prompted:

Line: 858
Char: 1
Error: Object doesn't support this action
Code: 0
URL: http://www.dojotoolkit.org

Line: 23
Char: 4
Error: Object doesn't support this property or method

And then, the content of "News & Announcements" was blanked out. Clicking on "See it in action" and "Get Help" didn't seem to work.

There is no problem if I used v6.0.2900.2180.xpsp_sp2_gdr.050301-1519CO.

As this bug may lead to the decision on whether we should continue to use dojo or not, I mark this as high priority and blocker.

Change History (2)

comment:1 Changed 13 years ago by James Burke

Cc: kathyhkchan-dojo@… added
Resolution: worksforme
Status: newclosed

I just tried on Windows XP SP2 with IE 6.0.2900.2180.xpsp_sp2_gdr.050301-1519, and I went to:

http://www.dojotoolkit.org

I did not get any script error. I could see the News and Announcements text. I have "Display Notification of Every Script Error" turned on, and debugging is enabled.

The only oddity I saw was a lack of correct P3P headers, but that is a web server configuration thing, not a Toolkit issue. And it only shows a red icon in the toolbar, it does not seems to generate any script errors for me.

Perhaps you have a special firewall or antivirus package that might be interfering with the correct delivery of the source?

I'm closing the bug for now since I cannot reproduce, but feel free to re-open if you find more information.

comment:2 Changed 13 years ago by kathyhkchan-dojo@…

Thanks for the response.

I figure that the browser addon, mwsBar BHO (My WebSearch?.com) MWSBAR.DLL, caused the trouble. Disable it, the website works fine. I'm not sure why, but good to know for reference.

Note: See TracTickets for help on using tickets.