Opened 12 years ago

Closed 10 years ago

#2232 closed defect (invalid)

Sometimes Dojo Storage Doesn't Work On Windows When Flash Libraries First Load

Reported by: bradneuberg Owned by: bradneuberg
Priority: blocker Milestone: 1.1
Component: Storage/Flash Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description

This one is subtle; sometimes, when you bring Dojo Storage up for the first time on Windows on Internet Explorer (and maybe Firefox, can't remember), it will ocassionally not work for the first time. When you refresh the page it now always works going forward. I run into this on my brothers PC sometimes (Bryan Neuberg). My running theory is that this is because Flash itself has never been loaded by the system, and the very first time it loads due to Dojo Storage a timing issue causes it to not work. This bug is hard to replicate and doesn't happen too often, but it does, which concerns me; I want to stamp this one out to increase the reliability of Dojo Storage using the FlashStorageProvider?.

Change History (4)

comment:1 Changed 12 years ago by bradneuberg

Summary: Sometimes Dojo Storage Doesn't WorkSometimes Dojo Storage Doesn't Work On Windows When Flash Libraries First Load

comment:2 Changed 11 years ago by dylan

Milestone: 0.91.0

comment:3 Changed 11 years ago by bradneuberg

Milestone: 1.01.1

I've never been able to reproduce this. Leaving open but bumping to 1.1.

comment:4 Changed 10 years ago by bradneuberg

Resolution: invalid
Status: newclosed

I saw this a long time ago but haven't seen it for awhile. Marking as INVALID.

Note: See TracTickets for help on using tickets.