Opened 13 years ago

Closed 13 years ago

#2189 closed defect (fixed)

ComboBox - dojo crashes when loaded in a child window in FF2

Reported by: acirov@… Owned by: Douglas Hays
Priority: high Milestone: 0.9
Component: Widgets Version: 0.4.1
Keywords: ComboBox Cc:
Blocked By: Blocking:

Description

ComboBox? is crashing in FF 2.0 if loaded remotely in a child window. If you open a child window, on the first attempt everything works fine. On the second loading of the page, there is an unhandled exception in dojo.js (line 96) when you try to select an element from the suggestions list. Combo continues to work with some glitches but FormBind? for example doesn't. This is the case even if the page is loaded with different parameters. In IE this is working normally.

It's a caching related issue. If I clear the cache between attempts, everything works fine. I tried several things to avoid caching but with no luck so far.

Change History (5)

comment:1 Changed 13 years ago by acirov@…

Putting <meta http-equiv="EXPIRES" content="0" /> solves this problem, so I can confirm it's a caching issue.

comment:2 Changed 13 years ago by acirov@…

Nope, I rushed to judgment. Problem still persists. It's a cashing issue because if I hit F5 everything works fine.

I also notices that this is not limited to the ComboBox? widget. FormBind? with no dojo widget objects has the same problem.

comment:3 Changed 13 years ago by acirov@…

I must correct myself, putting <meta http-equiv="EXPIRES" content="0" /> solves the problem. I had a parsing issue elsewhere.

comment:4 Changed 13 years ago by Douglas Hays

Owner: changed from bill to Douglas Hays

comment:5 Changed 13 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [8352]) Port of ComboBox?(=AutoCompleter?) and Select widgets to 0.9 dojo by haysmark@…. Fixes #2189, #1504, #1451, #2244, #2384, #2070, #899, #912, #1267, #1339, #1456, #1484, #1485, #2558, #1186

Note: See TracTickets for help on using tickets.