Opened 13 years ago

Closed 13 years ago

#2175 closed defect (invalid)

editor2: bullet list feature breaks HTML

Reported by: guest Owned by: liucougar
Priority: high Milestone: 0.9
Component: Editor Version: 0.4.1
Keywords: editor2 bullet list Cc:
Blocked By: Blocking:

Description

  1. enter the following text in the editor: test1 test2
  1. mark the text and press the <bullet list> button in the toolbar
  1. position cursor before test2 and klick enter (--> a second bullet is created)
  1. press the delete button again (should "merge" the two lines into one bullet)

but what happens is: both bullets disappear...

...and the HTML looks like this:

<ul>

<>test1 test2</>

</ul>

(Mozilla 1.7.3 - dojo4.1 from trunk)

Change History (3)

comment:1 Changed 13 years ago by liucougar

I can not reproduce it

in step 4, when I press delete, the t in test2 is deleted

I use FF 2.0

comment:2 Changed 13 years ago by guest

yes, FF2 works fine. The bug occurs in Mozilla 1.7.3 Maybe it´s not too much effort to fix this bug for "such an old browser"...

comment:3 Changed 13 years ago by liucougar

Resolution: invalid
Status: newclosed

uhm, then that's definitely a M1.7.3 bug

I don't think I will investigate a workaround for this 'old' browser, so closing. If you can find a workaround, patch is welcome

Note: See TracTickets for help on using tickets.