Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#217 closed defect (worksforme)

LayoutPane: invalid url causes cpu spin

Reported by: bill Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.1
Keywords: Cc:
Blocked By: Blocking:

Description

From David Wynter:

[using HtmlLayoutPane?. w/url="..." constructor argument] if you mispelt one of the external URLs in your page ( I did with portfoliodetail.htmlm ) then dojo recursively tries to load the whole screen into that pane and Firefox sits there at 50% CPU for a long time.

Change History (2)

comment:1 Changed 14 years ago by bill

Resolution: worksforme
Status: newclosed

Hmm, I can't reproduce this. Maybe David was using file:// instead of http://? file:// doesn't work very well with dojo.io.bind. Anyway, ContentPane?'s href seems to fail gracefully if it's an invalid URL.

comment:2 Changed 13 years ago by (none)

Milestone: 0.3release

Milestone 0.3release deleted

Note: See TracTickets for help on using tickets.