Opened 13 years ago

Closed 12 years ago

#2163 closed enhancement (fixed)

only one waiState can be specified per element within a template

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 0.9
Component: Accessibility Version: 0.4.1
Keywords: a11y Cc:
Blocked By: Blocking:

Description

The waiRole or waiState can be specified in a widget template. This is implemented in dojo.widget.attachTemplateNodes via dojo.lang.forEach(dojo.widget.waiNames, function(name){....}. Currently, if there are multiple states specified, only the first one is parsed. I'm not sure if this is by design or not (sorry, I haven't investigated into the code, yet). Here is a possible excerpt from the slider template:

<table _="weird end tag formatting is to prevent whitespace from becoming &nbsp;"

class="sliderMain" dojoAttachPoint="focusNode" waiRole="slider" waiState="valuenow-${this.initialValue}" waiState="valuemin-${this.minimum}" waiState="valuemax-${this.maximum}" dojoAttachEvent="onmousedown:_setFocus; onkey:_handleKeyEvents; onkeyup:_buttonReleased; onmouseup:_buttonReleased; onmousewheel:_mouseWheeled;" tabindex="0" cols=3 cellpadding=0 cellspacing=0 style="">

currently only the first waiState encountered (valuenow) gets set.

Change History (2)

comment:1 Changed 12 years ago by davidb

Component: WidgetsAccessibility
Owner: changed from bill to Becky Gibson

comment:2 Changed 12 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

(In [8962]) allow multiple waiStates in a widget template fixes #2163

Note: See TracTickets for help on using tickets.