Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#215 closed defect (duplicate)

Text Editor, Firefox crash

Reported by: anonymous Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.2
Keywords: Firefox, Editor, Textarea Cc:
Blocked By: Blocking:

Description

I am trying (from the Nov 26th nightly build) the new 'Editor Widget' that is coming out in 1.2. It works like a charm in IE, but if I set a textarea as the editor, it hangs in Firefox (1.07), and if I refresh the page, it crashes the browser.

page source: <script type="text/javascript"> djConfig = { isDebug: true }; </script> <script type="text/javascript" src="/dojo/dojo.js"></script> <script type="text/javascript">

dojo.require("dojo.widget.RichText?"); dojo.require("dojo.widget.Editor");

</script>

<textarea dojoType="Editor" items="bold;italic;|;blockGroup;justifyGroup;forecolor;createlink;listGroup" class="hidden" cols="50" rows="35">

Here is a test

</textarea>

If I click on any of the buttons in the toolbar before the browser crashes, the FF javascript console returns:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMNSHTMLDocument.execCommand]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: http://------------------/dojo/src/bootstrap1.js :: anonymous :: line 881" data: no]

Source File: http://church.m9studios.com/dojo/src/bootstrap1.js Line: 881

Hope this helps.

Change History (2)

comment:1 Changed 14 years ago by alex

Milestone: 0.2release
Resolution: duplicate
Status: newclosed

this is fixed in rev [2239]. Dojo 0.2 will contain the fix, until then you can grab a fixed nightly build from http://archive.dojotoolkit.org

Resolving as a dupe of #207

comment:2 Changed 12 years ago by (none)

Milestone: 0.2release

Milestone 0.2release deleted

Note: See TracTickets for help on using tickets.