Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2100 closed defect (fixed)

tree drag'n'drop is broken

Reported by: ornus Owned by: alex
Priority: high Milestone:
Component: General Version: 0.4.1rc1
Keywords: tree Cc: sol@…
Blocked By: Blocking:

Description

when dragging starts an exception is thrown

Change History (7)

comment:1 Changed 13 years ago by Adam Peller

Resolution: invalid
Status: newclosed

please indicate what the exception was. Alex just fixed a similar ticket #2034, perhaps that's what you saw?

comment:2 Changed 13 years ago by ornus

Resolution: invalid
Status: closedreopened

exception message in Mozilla

DEBUG: [TypeError: dragObjects[i].dragSource has no properties, file: file:///dojo/src/dnd/TreeDragAndDropV3.js, line: 134] when calling onMouseMove$joinpoint$method on [object Object] with arguments [object Object]
FATAL exception raised: dragObjects[i].dragSource has no properties

I tried with the latest trunk (r6807) and there's still a problem

comment:3 Changed 13 years ago by Adam Peller

Owner: changed from anonymous to alex
Status: reopenednew

Alex -- this seems to have regressed with [6805]

comment:4 Changed 13 years ago by bill

Resolution: fixed
Status: newclosed
Version: 0.4.10.4.1rc1

There's no testcase filed w/this bug. I tried demos/widget/Tree/tree.html. It throws an exception before Alex's checkin, but works after Alex's checkin.

comment:5 Changed 13 years ago by ornus

Resolution: fixed
Status: closedreopened

I'm sorry for not posting test case, totally my fault. I'll do my best to remember about it in the future.

to reproduce the bug open *testswidget reeV3dnd1.html* and start dragging any node.

comment:6 Changed 13 years ago by alex

Resolution: fixed
Status: reopenedclosed

(In [6811]) fixes #2100

comment:7 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.