Opened 13 years ago

Closed 13 years ago

#2090 closed defect (duplicate)

dojo-0.4.1rc3-widget testing

Reported by: mumme Owned by: mumme
Priority: high Milestone: 0.9
Component: General Version: 0.4.1
Keywords: 0.4.1rc3 testing Cc: alex@…
Blocked By: Blocking:

Description (last modified by bill)

Not really sure what this means

[quot] Alex is rolling RC3 right now. Please, please, don't make any further check-ins to the RC3 branch without clearing with the release manager (Alex) [end quot]

I take it you mean that we shouldn't checkin before approval, so I attach my patches here along with other minor issues I found.

test_Dialog_createWidget.html fails to hide, moz, opera, khtml

--- test_Dialog_createWidget.html	(revision 6789)
+++ test_Dialog_createWidget.html	(working copy)
@@ -16,8 +16,8 @@
 //	dlg = dojo.widget.byId("DialogContent");
 	dlgProg = dojo.widget.createWidget("dojo:Dialog",{toggle:"fade",toggleDuration:250}, dojo.byId("dialogNode"));
 	dojo.debug(dlgProg.domNode.innerHTML);
-//	var btn2 = document.getElementById("hider2");
-//	dlgProg.setCloseControl(btn2);
+	var btn2 = document.getElementById("hider2");
+	dlgProg.setCloseControl(btn2);
 }
 dojo.addOnLoad(init);

test_FloatingPane.html layout test show in the wrong order:

top bottom left right center

--- src/widget/FloatingPane.js	(revision 6789)
+++ src/widget/FloatingPane.js	(working copy)
@@ -12,6 +12,7 @@
 dojo.require("dojo.dnd.HtmlDragMove");
 dojo.require("dojo.widget.Dialog");		// for ModalFloatingPane
 dojo.require("dojo.widget.ResizeHandle");
+dojo.require("dojo.widget.LayoutContainer");
 
 dojo.declare(
 	"dojo.widget.FloatingPaneBase",

test_Menu2.html, Khtml, doesn't show the items in the menubar

broke by the checkin 6704 to dom.js (Worked ok for 0.4.0)

*

Minor and/or known issues below:

test_ComboBox.html, Khtml only, only the the first one in the page works after tabbing around a while *

closing outside dialog doesn't work in Khtml (suspect its because opacity div isn't showing) *

test_FloatingPane.html Khtml click on tree generates javascript error (activate javascript, alert on errors)

labelNode.label is not an object, cannot be called dojo.widget.TreeBasicControllerV3

Minor issue as it only occurs when Javascript error alert is turned on, that is so annoying so most user probably turned that off. Bug in Khtml that it wont show up in the script console? *

Also I would be good if we could select 0.4.1rc3 in the bug ticket version.

/ Fredrik

Change History (3)

comment:1 Changed 13 years ago by mumme

Cc: alex@… added

The Menubar not showing up, appears to be caused by the constructing divs is left in the DOM, and as the TD's is appended to TR before the divs after #6704 it causes a missrendering.

a workaround:

Index: Menu2.css
===================================================================
--- Menu2.css	(revision 6789)
+++ Menu2.css	(working copy)
@@ -106,6 +106,8 @@
 	vertical-align: middle;
 	z-index: 1;
 	padding: 3px 8px;
+
+	display: inline;/* needed in khtml to display correctly */
 }
 
 .dojoMenuBarItem2 span {

comment:2 Changed 13 years ago by bill

Description: modified (diff)
Milestone: 0.4.10.5
Owner: changed from alex to mumme
Version: 0.4.1rc10.4.1

Please file separate bugs for each item and also check in fixes (above) to trunk.

comment:3 Changed 13 years ago by mumme

Resolution: duplicate
Status: newclosed

Ok, sorry for doing it wrong :/

I opened up tickets #2130-#2134 so I close this as duplicate

/ Fredrik

Note: See TracTickets for help on using tickets.