Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2080 closed defect (fixed)

intern-strings of CSS for widgets not checking for duplicate additions?

Reported by: James Burke Owned by: James Burke
Priority: high Milestone:
Component: General Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description

There was an issue reported on dojo-interest that seems to indicate that with interned CSS, the CSS might be added to the DOM for every widget or widget instance that references that templateCssString.

We should check to be sure templateCssString style additions check for dupes, but also make sure we don't break subclasses that might define a different templateCssString or templateCssPath.

This issue might also be the cause of ticket #1958

Change History (4)

comment:1 Changed 13 years ago by James Burke

Owner: changed from anonymous to James Burke

I'm going to pick this up for now, but Adam Peller might be looking at #1958 which also might lead him to this issue, so I'll check with him. Also, if anyone else wants to take the ticket or has suggestions on the fix, feel free to comment.

comment:2 Changed 13 years ago by James Burke

(In [6788]) References #2080: insertion of templateCssString not checking for dupes

comment:3 Changed 13 years ago by James Burke

Resolution: fixed
Status: newclosed

(In [6789]) Fixes #2080: insertion of templateCssString not checking for dupes (merge from trunk)

comment:4 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.