Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#207 closed defect (fixed)

Rich Text Editor broken in Firefox

Reported by: jdunck@… Owned by: alex
Priority: high Milestone:
Component: Widgets Version: 0.1
Keywords: editor firefox Cc:
Blocked By: Blocking:

Description

This isn't my bug, so I'm just pasting stuff out of the mailing list here...

---------- Forwarded message ----------
From: mike jones <michael.daniel.jones@gmail.com>
Date: Nov 19, 2005 6:27 PM
Subject: [Dojo-interest] Rich text text area
To: dojo-interest@dojotoolkit.org


Hi 
 I am trying to integreate the rich text area into my app and use the behaviour described to create the widget out of a text area eg
 
 <textarea dojoType="Editor" name="editorContent"
 items="bold;italic;underline;strikethrough;">
 some content
</textarea>
 However this doesnt seem to work in firefox :( and when I access the parameter in the application following the submit in internet explorer the value is empty.
 I have tried this with the nightly builds and checked out the latest from svn trunk but get the same results.
 I have attached the output from my app incase its of any help.
 Thanks for any help
 Cheers
 Mike
---------- Forwarded message ----------
From: Alex Russell <alex@dojotoolkit.org>
Date: Nov 20, 2005 7:17 AM
Subject: Re: [Dojo-interest] Rich text text area
To: dojo-interest@dojotoolkit.org


On Sunday 20 November 2005 5:09 am, mike jones wrote:
> Hi
> I just downloaded
> ajax-2005-11-20.zip<http://archive.dojotoolkit.org/nightly-profiles/a
>jax-2005-11-20.zip>from
> http://archive.dojotoolkit.org/nightly-profiles/ and that doesnt work
> either. Which version did you download?

Now I'm terribly confused. I just downloaded this nightly, unzipped it
and loaded the Editor file from the demo directory and it worked. What
is broken for you?

Regards

--
Alex Russell
---------- Forwarded message ----------
From: Alex Russell <alex@dojotoolkit.org>
Date: Nov 20, 2005 6:23 PM
Subject: Re: [Dojo-interest] Rich text text area
To: dojo-interest@dojotoolkit.org


Turns out this is a nasty timing issue with Firefox. Mozilla's rich text
editing support is significantly less polished and/or stable than IE's,
so this is going to require some creative thinking to get it sorted
out. I'll post back if/when I have better news.

Sorry for the trouble = 

Regards

Attachments (1)

pagefromapp.html (5.8 KB) - added by jdunck@… 14 years ago.
repro html from mailing list

Download all attachments as: .zip

Change History (7)

Changed 14 years ago by jdunck@…

Attachment: pagefromapp.html added

repro html from mailing list

comment:1 Changed 14 years ago by anonymous

Milestone: 0.2release
Version: 0.20.1

comment:2 Changed 14 years ago by alex

Owner: changed from anonymous to alex
Status: newassigned

comment:3 Changed 13 years ago by alex

Resolution: fixed
Status: assignedclosed

(In [2339]) the rich text editor now works when being created from a <textarea>. Big thanks go out to Rus Heywood for suggesting the fix. Fixes #207

comment:4 Changed 13 years ago by john@…

Resolution: fixed
Status: closedreopened

Textarea edit still not functioning in Firefox and IE.

comment:5 Changed 13 years ago by alex

Resolution: fixed
Status: reopenedclosed

John, I don't think your understanding of the bug is the same as what's been filed in this issue. Please files a new bug with a new testcase and a description of the expected behavior.

comment:6 Changed 12 years ago by (none)

Milestone: 0.2release

Milestone 0.2release deleted

Note: See TracTickets for help on using tickets.