Opened 13 years ago

Closed 13 years ago

#2054 closed task (fixed)

Get RSS feed from Blog to redesigned web site front page

Reported by: owen Owned by: Dustin Machi
Priority: high Milestone:
Component: Website Version: 0.4
Keywords: Cc: owen tk
Blocked By: Blocking:

Description

Tom, please upload the stylesheet and pass of to Dustin. Dustin, if you're unclear on what this is about, please ask Alex.

Attachments (1)

atom.xsl (1.7 KB) - added by Tom Trenka 13 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 13 years ago by Tom Trenka

Owner: changed from Tom Trenka to Dustin Machi

This stylesheet was designed to work off of the Atom feed and not the RSS one (a little more detail is available with the atom feed). I've no idea how the original feed getter worked, so you might end up having to talk to Alex about it.

There are also a couple of things that need to be understood about this:

  1. The redesign used a slashdot entry for some reason; it should have used data from the Dojo blog. Because of that, there are quite a few things that are simply impossible to pull using the Atom or RSS feed, such as the # of comments, any category image, there are no departments, etc.
  2. I've no idea where that tagging thing came from; it's not implemented.

I was *not* able to test this stylesheet out in full yet; apparently installing IE7 not only kills any existing CHM files that used the IE engine to render contents, but it also killed the XSL debugger I have (Altova XMLSpy). In addition, all the major browsers have decided that when it comes to feeds, they should handle transformations, making straight up browser transformation tests impossible. Grr. I'll continue to work on it and double check the stylesheet; if there are changes made, I'll repost here.

comment:2 Changed 13 years ago by Tom Trenka

This stylesheet is set up to only grab the first 4 blog entries in the feed, and it's set up to display the *full* contents of the blog entry, not just a summary.

If people want the behavior to be different, let me know via email (ttrenka at gmail).

Changed 13 years ago by Tom Trenka

Attachment: atom.xsl added

comment:3 Changed 13 years ago by tk

Cc: owen tk added; owen removed

Is/will this still be relevant once the current beta site goes live?

comment:4 Changed 13 years ago by Dustin Machi

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.