Opened 13 years ago

Closed 12 years ago

#2045 closed defect (duplicate)

browser.undo dose not work in Firefox when "url" parameter of dojo.undo.browser.addToHistory is URI-encoded.

Reported by: guest Owned by: Ben Lowery
Priority: high Milestone: 1.1
Component: General Version: 0.4.1rc1
Keywords: Cc:
Blocked By: Blocking:

Description

In Firefox, if location.hash is set to an uri-encoded value, the return value of location.hash becames uri-decoded value.

Example:

location.hash = encodeURIComponent("%24");
alert(location.hash); // -> "$"

Therefore, browser.undo dose not work when "url" parameter of dojo.undo.browser.addToHistory is URI-encoded.

Change History (5)

comment:1 Changed 13 years ago by alex

Milestone: 0.4.10.5

comment:2 Changed 13 years ago by James Burke

Owner: changed from anonymous to James Burke

comment:3 Changed 12 years ago by Adam Peller

Owner: changed from James Burke to Ben Lowery

comment:4 Changed 12 years ago by bill

Milestone: 0.91.1

comment:5 Changed 12 years ago by James Burke

Resolution: duplicate
Status: newclosed

Closing as duplicate of #4777, which has a fix.

Note: See TracTickets for help on using tickets.