Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2025 closed defect (fixed)

tree widget in 04.1rc2 break under IE

Reported by: admin@… Owned by: bill
Priority: blocker Milestone:
Component: Widgets Version: 0.4.1rc1
Keywords: Cc:
Blocked By: Blocking:

Description

hey,

im using tree widget that i create via markup and then populate the tree with json data like:

category_node[categories_nodes[i].id] = dojo.widget.createWidget("TreeNodeV3", {title: "blah blah", tree: dojo.widget.byId('tree').widgetId});

then i do:

dojo.widget.byId('tree').addChild(category_node[categories_nodes[i].id]);

it worked ok in 0.4 , 0.4.1rc1 but now on 0.4rc2, strange things happen under ie, nodes dissappear from tree on move, functions like setting new content to contentpane dont work etc.

this only has place under IE and when i do dojo.widget.byId(sometreenode).addChild(somenewnode);

occurs under IE6 , windows 2k3

Attachments (1)

index.html (8.1 KB) - added by guest 13 years ago.
test case - doesnt behave correctly under rc2

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by bill

Attach a testcase. Also, try with the latest code from SVN, I think this might have been fixed already.

comment:2 Changed 13 years ago by jkuhnert

Resolution: worksforme
Status: newclosed

Under IE7 this seems to work fine for me. I used http://archive.dojotoolkit.org/nightly/tests/widget/treeV3/program1.html to test (not literally that file, one running in the 0.4.1 branch) against ie7 and all was well.

Perhaps looking at the program1.html test will shed some light on this?

comment:3 Changed 13 years ago by guest

Resolution: worksforme
Status: closedreopened

hey, its not the problem that it doesnt work at all, this happens only in IE: the tree gets populated properly, but then something happens ( dont know how to nail where) , and tree node dissappears when trying to muve up or down, i cannot set new content to contentpane that had this widget inside etc. everything breaks .

it breaks here: dojo.widget.byId('tree').addChild(category_node[categories_nodes[i].id]); when removing the lines that add childs to the tree, contentpane can have new content and things seem to work.

in rc1 , and 0.4 e4verything is ok

comment:4 Changed 13 years ago by guest

when i try to set new content to contentpane on second call i get : DEBUG: widget ID collision on ID: tree

comment:5 Changed 13 years ago by guest

ive tried to change the main dojo.js file from 0.4.1rc2-ajax , to 0.4.1rc1-kitchen-sink, to its not the widgets fault but something more general, what report should i file ?

comment:6 Changed 13 years ago by bill

Milestone: 0.4.10.5

I tested treeV3/dnd1.html on IE6 and it worked fine for me. I wasn't joking before. You need to attach a testcase.

Changed 13 years ago by guest

Attachment: index.html added

test case - doesnt behave correctly under rc2

comment:7 Changed 13 years ago by guest

i have been able to assemble a test case that behaves exactly as i wrote: works in version prior to .4.1rc2

comment:8 Changed 13 years ago by guest

the problem seems fixed for 0.4.1rc3 ;-) can be closed. thank you very much. you are doing grat job!

comment:9 Changed 13 years ago by bill

Milestone: 0.50.4.1
Resolution: fixed
Status: reopenedclosed

comment:10 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.